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Microsoft Excel is a commercial spreadsheet application, written and distributed by Microsoft for 

Microsoft Windows and Mac OS X. Microsoft Excel is a spreadsheet tool capable of performing 

calculations, analyzing data and integrating information from different programs. 

By default, documents saved in Excel 2010 are saved with the .xlsx extension whereas the file 

extension of the prior Excel versions are .xls. 

The following basic window appears when you start the excel application. Let us now 

understand the various important parts of this window. 
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File Tab 

The File tab replaces the Office button from Excel 2007. You can click it to check the Backstage 

view, where you come when you need to open or save files, create new sheets, print a sheet, and 

do other file-related operations. 

Quick Access Toolbar 

You will find this toolbar just above the File tab and its purpose is to provide a convenient 

resting place for the Excel's most frequently used commands. You can customize this toolbar 

based on your comfort. 

Ribbon 

 

Ribbon contains commands organized in three components − 

 Tabs − They appear across the top of the Ribbon and contain groups of related 

commands. Home, Insert, Page Layout are the examples of ribbon tabs. 

 Groups − They organize related commands; each group name appears below the group 

on the Ribbon. For example, group of commands related to fonts or group of commands 

related to alignment etc. 

 Commands − Commands appear within each group as mentioned above. 

Title Bar 

This lies in the middle and at the top of the window. Title bar shows the program and the sheet 

titles. 

Entering values in excel sheet is a child’s play and this chapter shows how to enter values in an 

excel sheet. A new sheet is displayed by default when you open an excel sheet as shown in the 

below screen shot. 
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Sheet area is the place where you type your text. The flashing vertical bar is called the insertion 

point and it represents the location where text will appear when you type. When you click on a 

box then the box is highlighted. When you double click the box, the flashing vertical bar appears 

and you can start entering your data. 

So, just keep your mouse cursor at the text insertion point and start typing whatever text you 

would like to type. We have typed only two words "Hello Excel" as shown below. The text 

appears to the left of the insertion point as you type. 
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There are following three important points, which would help you while typing − 

 Press Tab to go to next column. 

 Press Enter to go to next row. 

 Press Alt + Enter to enter a new line in the same column. 

Saving New Sheet 

Once you are done with typing in your new excel sheet, it is time to save your 
sheet/workbook to avoid losing work you have done on an Excel sheet. Following are 
the steps to save an edited excel sheet − 

Step 1 − Click the File tab and select Save As option. 
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Step 2 − Select a folder where you would like to save the sheet, Enter file name, which 
you want to give to your sheet and Select a Save as type, by default it is .xlsx format. 
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Step 3 − Finally, click on Save button and your sheet will be saved with the entered 

name in the selected folder. 

Saving New Changes 

There may be a situation when you open an existing sheet and edit it partially or 
completely, or even you would like to save the changes in between editing of the sheet. 
If you want to save this sheet with the same name, then you can use either of the 
following simple options − 

 Just press Ctrl + S keys to save the changes. 

 Optionally, you can click on the floppy icon available at the top left corner and just 
above the File tab. This option will also save the changes. 

 You can also use third method to save the changes, which is the Save option 
available just above the Save As option as shown in the above screen capture. 

If your sheet is new and it was never saved so far, then with either of the three options, 
word would display you a dialogue box to let you select a folder, and enter sheet name 
as explained in case of saving new sheet. 

You can assign any of the fonts that is installed for your printer to cells in a worksheet. 

Setting Font from Home 

You can set the font of the selected text from Home » Font group » select the font. 

 

 

Setting Font From Format Cell Dialogue 
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 Right click on cell » Format cells » Font Tab 

 Press Control + 1 or Shift + Control + F 

 

Formulas in MS Excel 

Formulas are the Bread and butter of worksheet. Without formula, worksheet will be just 
simple tabular representation of data. A formula consists of special code, which is 
entered into a cell. It performs some calculations and returns a result, which is displayed 
in the cell. 

Formulas use a variety of operators and worksheet functions to work with values and 
text. The values and text used in formulas can be located in other cells, which makes 
changing data easy and gives worksheets their dynamic nature. For example, you can 
quickly change the data in a worksheet and formulas works. 

Elements of Formulas 

A formula can consist of any of these elements − 

 Mathematical operators, such as +(for addition) and *(for multiplication) 
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Example − 

o =A1+A2 Adds the values in cells A1 and A2. 

 Values or text 

Example − 

o =200*0.5 Multiplies 200 times 0.15. This formula uses only values, and it 
always returns the same result as 100. 

 Cell references (including named cells and ranges) 

Example − 

o =A1=C12 Compares cell A1 with cell C12. If the cells are identical, the 
formula returns TRUE; otherwise, it returns FALSE. 

 Worksheet functions (such as SUMor AVERAGE) 

Example − 

o =SUM(A1:A12) Adds the values in the range A1:A12. 

Creating Formula 

For creating a formula you need to type in the Formula Bar. Formula begins with '=' sign. 
When building formulas manually, you can either type in the cell addresses or you can 
point to them in the worksheet. Using the Pointing method to supply the cell addresses 
for formulas is often easier and more powerful method of formula building. When you are 
using built-in functions, you click the cell or drag through the cell range that you want to 
use when defining the function’s arguments in the Function Arguments dialog box. See 
the below screen shot. 
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As soon as you complete a formula entry, Excel calculates the result, which is then 
displayed inside the cell within the worksheet (the contents of the formula, however, 
continue to be visible on the Formula bar anytime the cell is active). If you make an error 
in the formula that prevents Excel from being able to calculate the formula at all, Excel 
displays an Alert dialog box suggesting how to fix the problem. 

Functions in Formula 

Many formulas you create use available worksheet functions. These functions enable 
you to greatly enhance the power of your formulas and perform calculations that are 
difficult if you use only the operators. For example, you can use the LOG or SIN function 
to calculate the Logarithm or Sin ratio. You can’t do this complicated calculation by using 
the mathematical operators alone. 

Using Functions 

When you type = sign and then type any alphabet you will see the searched functions 
as below. 
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Suppose you need to determine the largest value in a range. A formula can’t tell you the 
answer without using a function. We will use formula that uses the MAX function to return 
the largest value in the range B3:B8 as =MAX(A1:D100). 

 

Another example of functions. Suppose you want to find if the cell of month is greater 
than 1900 then we can give Bonus to Sales representative. The we can achieve it with 
writing formula with IF functions as =IF(B9>1900,"Yes","No") 
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Convert Data Into a Table in Excel 
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This page will show you how to convert Excel data into a table. 

Creating a Table within Excel 

1. Open the Excel spreadsheet. 

2. Use your mouse to select the cells that contain the information for the table.  

3. Click the "Insert" tab > Locate the "Tables" group. 

4. Click "Table". A "Create Table" dialog box will open.  

5. If you have column headings, check the box "My table has headers". 

6. Verify that the range is correct > Click [OK]. 

7. Resize your columns to make the headings visible. 

Changing the Table Style 

1. Click on a cell in the table to activate the "Table Tools" tab. 

2. Click the "Design" tab > Locate the "Table Styles" group. 

3. Choose a style/color option that appeals to you. (Hover over the various table 

styles to see a live preview.) 

Sort and Filter the Data 

Your list is now an Excel Table, and is automatically formatted with a default Table 
Style, which you can change. The heading cells have drop down arrows that you can use 
to sort or filter the data. 

NOTE: In Excel 2013 and later, you can use Excel Table Slicers to quickly filter the table 
data. 

https://www.contextures.com/exceltableslicers.html
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Rename an Excel Table 

When it is created, an Excel table is given a default name, such as Table 3. You should 
change the name to something meaningful, so it will be easier to work with the table 
later. 

To change the table name: 

1. Select any cell in the table 
2. On the Ribbon, under the Table Tools tab, click the Design tab. 

 

3. At the far left of the Ribbon, click in the Table name box, to select the existing 
name 
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4. Then, type a new name, such as Orders, and press the Enter key 

 

 

Show Totals in a Table 

After you create an Excel table, it's easy to show the total for a column, or for multiple 
columns, using a built-in Table feature. 

To show a total: 

1. Select any cell in the table 
2. On the Ribbon, under the Table Tools tab, click the Design tab 
3. In the Table Style Options group, add a check mark for Total Row 
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4. A Total row will be added at the bottom of the table, and one or more column of 
numbers might show a total. 

Create a chart 

1. Select the data for which you want to create a chart. 

2. Click INSERT > Recommended Charts. 

3. On the Recommended Charts tab, scroll through the list of charts that Excel 

recommends for your data, and click any chart to see how your data will look. 

If you don’t see a chart you like, click All Charts to see all the available chart types. 

4. When you find the chart you like, click it > OK. 

5. Use the Chart Elements, Chart Styles, and Chart Filters buttons, next to the upper-

right corner of the chart to add chart elements like axis titles or data labels, customize 

the look of your chart, or change the data that is shown in the chart. 

6. To access additional design and formatting features, click anywhere in the chart to add 

the CHART TOOLS to the ribbon, and then click the options you want on 

the DESIGN and FORMAT tabs. 

Create a Chart 

To create a line chart, execute the following steps. 

1. Select the range A1:D7. 
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2. On the Insert tab, in the Charts group, click the Line symbol. 

 

3. Click Line with Markers. 
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Result: 

 

Note: enter a title by clicking on Chart Title. For example, Wildlife Population. 

Change Chart Type 

You can easily change to a different type of chart at any time. 

1. Select the chart. 

2. On the Design tab, in the Type group, click Change Chart Type. 

 

3. On the left side, click Column. 
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4. Click OK. 

Result: 
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Switch Row/Column 

If you want to display the animals (instead of the months) on the horizontal axis, execute 

the following steps. 

1. Select the chart. 

2. On the Design tab, in the Data group, click Switch Row/Column. 

 

Result: 
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Legend Position 

To move the legend to the right side of the chart, execute the following steps. 

1. Select the chart. 

2. Click the + button on the right side of the chart, click the arrow next to Legend and 

click Right. 
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Result: 

 

Data Labels 

You can use data labels to focus your readers' attention on a single data series or data 

point. 

1. Select the chart. 

2. Click a green bar to select the Jun data series. 

3. Hold down CTRL and use your arrow keys to select the population of Dolphins in June 

(tiny green bar). 

4. Click the + button on the right side of the chart and click the check box next to Data 

Labels. 
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Result: 

 

Use text-to-speech commands in Excel 

1. Next to the Quick Access Toolbar, click Customize Quick Access Toolbar, then 

click More Commands.. 
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2. In the Choose commands from list, select All Commands. 

3. Scroll down, and for each text-to-speech command that you want to use, click any of 

the Speak Cells command, and then click Add. 
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4. Click OK. 

5. When you want to use a text-to-speech command, click it the Quick Access Toolbar.  

 

Note: You can use the text-to-speech commands in Excel 2007 and 2003 by pointing 

to Speech on the Tools menu, and then clicking Show Text to Speech Toolbar. 

Play back worksheet data 

Note: You'll need to configure your computer audio to hear speech. 

https://support.microsoft.com/en-us/help/4026994/windows-fix-sound-problems
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Play back a group of cells 

To hear the speech that corresponds to the text in a group of cells, do the following: 

1. Select a group of cells to that you want to hear as audible speech. 

2. Choose how the computer will read back your data by clicking By Rows  or By 

Columns  . 

3. Click Speak Cells  . 

4. To correct an error, click Stop Speaking  , and then use your mouse and keyboard to 

make the necessary changes. 

5. Click Speak Cells  to make the computer continue to read back your selection. 

Tip: You can select a specific range of cells for the computer to read back to you. Or, 

you can click Speak Cells  without selecting any cells and Excel will automatically 

expand the selection to include the neighboring cells that contain values. 

Play back after every cell entry 

1. Click Speak On Enter  . 

2. Enter data in any cell. Press Enter, and the computer will read back the contents of the 

cell. 

Note: If you hide the Text To Speech toolbar and you did not turn off Speak On 

Enter  , the computer continues to read back each cell entry that you make. 

Click Speak On Enter  to turn it off. 

 


