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Introduction: 
Google Docs is a word processor included as part of a free, web-based Google Docs suite offered by Google 

within its Google Drive service. Google Docs is available as a web application; mobile app for Android, iOS, 

Windows, BlackBerry; and as a desktop application on Google's Chrome OS. The app is compatible with 

Microsoft Office file formats 

For Creating a file in google docs 

• The first thing you needed is a google account. 

• You can create a document file from google drive also. 

• If you are creating a document in your smart phone, then it automatically saved in google drive. 

• When try to create a file then it asks for two options 

o Blank document 

o From template document. 

Using templates 
A template is a pre-designed file you can use to quickly create new documents. Templates often include 

custom formatting and designs, so they can save you a lot of time and effort when starting a new project. 

Most templates are designed to help you create specific types of files. For instance, you could use a template 

to quickly create a resume or newsletter. 
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You can find a wide selection of templates in the Template Gallery. For this reason, we recommend using 

templates made by Google, which tend to be of higher quality than user-submitted templates. 

To use an official Google template: 

• Navigate to the template gallery. 

 
• When you've found a template you want to use, click the template to select it 
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• A new file will be created with the selected template. You can then customize the file with your own 

information 

 

Using Blank Document 

• Open Google Docs, and create a new blank file. 

• Change the document title from Untitled Document to Practice Document. 

Page setup options 

When you first create a Google document, you may want to change page setup options like page orientation, 

margins, or paper size, depending on the type of document you are creating. You can access these options by 

clicking Page setup in the File menu. 
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In the Page setup dialog, you can customize several options: 

Page orientation is whether your page is oriented in portrait or landscape format. Landscape format means the 

page is oriented horizontally, while portrait format means it is oriented vertically. 

 

Page margins are the gaps between the body of the document and the edge of the page. 

 

Paper size lets you change the dimensions of the page. This is particularly useful if you are printing the document 

on a custom paper size. 
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Page color is the background color of the document. This may be useful as a decorative option if you plan on 

publishing your document on the Web. 

 
 

To insert text: 

Locate the insertion point, which is a blinking vertical line. In a blank document, this will be near the top-left 

corner of the page. If the document already has text, you can click in different parts of the document to move the 

insertion point. 

When you begin typing, the text will appear next to the insertion point. 

 

To select text: 

Before you can move or format text, you'll need to select it. To do this, click and drag your mouse over the text, 

then release the mouse. A highlighted box will appear over the selected text. 
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Copying, cutting, and pasting text 

Typically, the copy, cut, and paste commands are found in the Edit menu of many word processing applications. 

However, Google Docs uses keyboard shortcuts—or a combination of keys—to perform these commands. If you 

try to select copy, cut, or paste from the Edit menu in Google Docs, Google reminds you to use keyboard 

shortcuts. 

 

To insert special characters: 

Google Docs offers a large collection of special characters. They are useful when writing equations, and they can 

serve as decorative accents as well. 

Place the insertion point where you want to insert a special character. 

Click Insert, then select Special characters. 
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The Insert Special Characters dialog box will appear. 

 

Spell check and suggested spelling 

By default, Google Docs will automatically check for misspelled words and make suggested spellings. Words 

with spelling suggestions are underlined in red. 
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To use suggested spelling: 

Right-click an underlined word. A drop-down menu with suggested spellings for the misspelled word will appear. 

Select the correct spelling from the list. 

 

The Toolbar Shortcut menu 

Google Docs offers a variety of text formatting options you can use to modify the look and feel of your document. 

These options are located in the Toolbar Shortcut menu. In the next few pages, you'll learn how these options can 

help enhance your document's appearance. 
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To change the font: 

Select the text you want to modify. 

 
 

 

Click the Font box from the toolbar. A drop-down menu of fonts appears. The name of each font has been 

formatted to look like the style it describes. 
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Select the font you want to use. In our example, we'll select the Roboto font. 

 
 

 

 

 

The selected text will change to the new font. 
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To use the bold, italic, and underline buttons: 

• Select the text you want to modify. 

• Click the bold (B), italic (I), or underline (U) button from the shortcut toolbar. 

 
• To change text alignment: 

• There are four alignment buttons in Google Docs. 

 

 
• The alignment buttons 

• Left align: Aligns all selected text to the left margin 

• Center align: Aligns text an equal distance from the left and right margins 

• Right align: Aligns all selected text to the right margin 

• Justify: Text is equal on both sides and lines up equally to the right and left margins; many newspapers 

and magazines use full justification 

Line and paragraph spacing 

In Google Docs, line spacing is measured in lines. For example, when text is double spaced, the line spacing is 

two lines high. You can reduce the line spacing to fit more lines on the page, or you can increase it to improve 

readability. 

 

To format line spacing: 

Select the text you want to format. 
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Click the Line spacing button, then select the desired line spacing option from the drop-down menu. You can also 

click Custom spacing to fine tune the spacing. 

Click the Insert link button, or right-click the selected text and click Link.

 

Hyperlinks 

A hyperlink is a link to a web address (or URL). If you want to include a web address in your Google document, 

you can format it as a hyperlink for someone to click. The hyperlink will then open the webpage in a new browser 

window. 

To insert a hyperlink: 

Hyperlinks have two basic parts: the address (URL) of the webpage and the display text. For example, the address 

could be http://www.apple.com/ipad and the display text could be Apple iPad. When you're creating a hyperlink 

in Google Docs, you'll be able to choose both the address and the display text. 

 

Select the text you want to make a hyperlink. 

Selecting text to hyperlink 
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Click the Insert link button, or right-click the selected text and click Link. 

 

The Edit Link dialog box will appear. In the Text field, the selected text will appear. You can modify this text if 

you want. 

Type the address you want to link to in the Link field. Google Docs may automatically fill in this field if the text 

you've selected looks like a URL. 

 

Click Apply. The text you selected will now be a hyperlink. 

To insert a table: 

• Place the insertion point at the location where you want to insert a table. 
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• Click the Table drop-down menu and hover the mouse over Insert table. A grid of squares appears. 

• Drag the mouse over the grid of squares to select the number of columns and rows in the table. 

• Click the mouse, and the table appears in the document. The insertion point will now be in the top-left 

cell. 

To upload an image: 

Place the insertion point in the document where you want to insert the image. 

Click Insert > Image > Upload from computer. 

To search for an image: 

Place the insertion point in the document where you want to insert the image. 

Click Insert > Image > Search the web. 

Other options for inserting images 

By URL: This option is useful if you have the URL of a particular image. When the URL is entered correctly in 

the Paste URL of image... field, a preview of the image will appear. Click Select to insert the image into your 

document. 

Your photos: Selecting Photos gives you access to your Google account profile images. If you use Google Photos 

to organize your photos, any albums you have created there will also be visible in the dialog box. Click an album 

to open it and select an image. 

Google Drive: If you have images stored in your Google Drive account, clicking Google Drive will give you 

access to these images. You have the option of sorting pictures to show all of the images in your Google Drive, 

only those shared with you, or only your most recently uploaded images. 

Using Google Docs on a mobile device 

The Google Docs app allows you to view and edit all of your Google docs on the go. Every change you make to 

your docs through the app will also show up in the browser version of Google Docs. You can even use the app to  

save and make changes to your docs when you're offline. Review our lesson on Using Google Docs Offline to 

learn how. 

The app vs. the browser 

The Google Docs app contains almost all of the same features as the web-based version, but there are some key 

differences between the two. 
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The mobile app lacks certain features, including the Ruler, shapes, headers and footers, and Suggesting mode. 

The Google Docs app allows you to view and edit your files, but if you want to create folders and organize them 

you'll need to download the Google Drive app as well. The Google Drive app is available for both iOS and 

Android.Depending on the mobile device you're using, your document may look different than it does on your  

 seen on a mobile device: 

   

   

Voice typing 

With Google Docs, using the keyboard isn’t your only option to add text. You can also just talk and have Google 

Docs transcribe the words for you. You can use this feature to transcribe meetings and audio recordings, or simply 

when you want to write faster than you can type. 

 

Watch the video below to learn more about voice typing in Google Docs. 

Typing with your voice 

Click Tools, then  select Voice typing. 
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Click the microphone in the small dialog box that appears. 

 

 

If a popup appears, click Allow. 

Start talking, and Google will transcribe what it hears. You can add punctuation using voice commands like 

comma and period. 

Translating documents 

If you ever have to share a document with people who speak a different language, don't worry. Google Docs 

makes it easy to translate documents. 
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In this lesson, you'll learn how to translate your document into over 100 different languages with just a few clicks. 

 

To translate a document: 

Click Tools, then select Translate document. 

 

In the dialog box, type a name for the translated document. In our example, we are adding the name of the new 

language at the beginning of the title. 

Use the drop-down menu to select the language that you want to translate the document into. 

Click Translate. A new tab will open with the translated Google Doc. 


